Server phpmyadmin error [gelöst]

Hier gehört alles hinein, dass mit der Version 16.04-LTS zu tun hat.
Diese Version wird bis April 2021 unterstützt
Antworten
Benutzeravatar
eltorro
Beiträge: 43
Registriert: Do 27. Sep 2018, 17:05
Ubuntu Version: 18
Wohnort: 1230

Server phpmyadmin error [gelöst]

Beitrag von eltorro » Do 19. Mär 2020, 07:47

Liebe Gemeinde,

Um mein DB Projekt einmal zu Starten habe ich mir einen alten Dell Laptop als 32 Bit 16.04 Server eingerichtet.
Da in vielen Fällen PHP 7.2 oder höher verlangt wird habe ich das ganze gleich mit PHP 7.4 installiert.

Jetzt bekomme ich mit phpmyadmin eine Reihe von Fehlern gelistet mit denen ich nicht wirklich etwas an zu fangen weiß..
Deprecation Notice in ./libraries/common.inc.php#267
Function get_magic_quotes_gpc() is deprecated

Backtrace

./index.php#12: require_once(./libraries/common.inc.php)
Deprecation Notice in ./libraries/common.inc.php#267
Function get_magic_quotes_gpc() is deprecated

Backtrace

./phpmyadmin.css.php#14: require_once(./libraries/common.inc.php)
Deprecation Notice in ./libraries/common.inc.php#267
Function get_magic_quotes_gpc() is deprecated

Backtrace

./db_structure.php#13: require_once(./libraries/common.inc.php)
Hat jemand von Euch eine gute Idee diese zu beheben?


Danke für euer Feedback
Bleibt gesund

LG Alois
Zuletzt geändert von eltorro am Sa 21. Mär 2020, 07:08, insgesamt 1-mal geändert.



Benutzeravatar
Webbutterfly
Administrator
Beiträge: 312
Registriert: Mi 29. Nov 2017, 16:53
Ubuntu Version: 18.04 ChromeOS
Wohnort: Wien
Kontaktdaten:

Re: Server phpmyadmin error

Beitrag von Webbutterfly » Fr 20. Mär 2020, 14:33

Ich denke mal, da ist die Version von Phpmyadmin nicht ganz kompatible mit der PHP-Veresion...
Welche Phpmyadmin-Version hast du installiert?

Ein PPA für PhPmyAdmin mit einer aktuellen Version (4.9.4) findest du hier:
https://launchpad.net/~phpmyadmin/+archive/ubuntu/ppa
European Open Source Center
www.eosc.eu

Benutzeravatar
eltorro
Beiträge: 43
Registriert: Do 27. Sep 2018, 17:05
Ubuntu Version: 18
Wohnort: 1230

Re: Server phpmyadmin error [gelöst]

Beitrag von eltorro » Sa 21. Mär 2020, 07:03

Nachdem ich immer wieder neue Phänomene hatte habe ich den Server neu installiert jedoch ohne automatische LAMP Installation...
Server nur mit ssh. dann habe ich eine manuelle Installation von PHP7.4 / apache2 / und MySql mit phpadmin durchgeführt.

Für jene die es interessiert:

Code: Alles auswählen

apt upgrade -y

apt install ca-certificates apt-transport-https lsb-release curl 

nano unzip -y

wget -q https://packages.sury.org/php/apt.gpg -O- | apt-key add

echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" | tee /etc/apt/sources.list.d/php.list

apt-get update

apt -y install software-properties-common

add-apt-repository ppa:ondrej/php

apt update

apt install apache2 -y 

apt install php7.4 php7.4-cli php7.4-curl php7.4-gd php7.4-intl php7.4-json php7.4-mbstring php7.4-mysql php7.4-opcache php7.4-readline php7.4-xml php7.4-xsl php7.4-zip php7.4-bz2 libapache2-mod-php7.4 -y

apt install mysql-server mysql-client -y

cd /usr/share

wget https://www.phpmyadmin.net/downloads/phpMyAdmin-latest-all-languages.zip -O phpmyadmin.zip 

unzip phpmyadmin.zip

rm phpmyadmin.zip

mv phpMyAdmin-*-all-languages phpmyadmin

chmod -R 0755 phpmyadmin

nano /etc/apache2/conf-available/phpmyadmin.conf
        
       # phpMyAdmin Apache configuration

Alias /phpmyadmin /usr/share/phpmyadmin

<Directory /usr/share/phpmyadmin>
 Options SymLinksIfOwnerMatch
 DirectoryIndex index.php
</Directory>

# Disallow web access to directories that don't need it
<Directory /usr/share/phpmyadmin/templates>
 Require all denied
</Directory>
<Directory /usr/share/phpmyadmin/libraries>
 Require all denied
</Directory>
<Directory /usr/share/phpmyadmin/setup/lib>
 Require all denied
</Directory>
       
       Speichern  STRG + O, STRG + X 
       
a2enconf phpmyadmin
       
systemctl reload apache2

mkdir /usr/share/phpmyadmin/tmp/

chown -R www-data:www-data /usr/share/phpmyadmin/tmp/
danach noch eine kleine Anpassung der "config.inc.php" unter /usr/share/phpmyadmin/
die Zeile
$cfg['blowfish_secret'] = ''; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */
mit einem mindesten 32 Zeichen Schlüsselwort versehen.

Das wars, alles läuft sauber ohne Fehler

Die Quelle die mir dabe geholfen hat:
https://www.bennetrichter.de/anleitunge ... hpmyadmin/

Jetzt geht es weiter, aber da mache ich ein neues Thema auf ;-)

Danke und LG bleibt gesund

Alois

Antworten