Lautsprecher knack'sen ....

Hier kommen alle Fragen über Ubuntu hinein, für die es kein spezielles Forum gibt.
angelwer1953
Beiträge: 30
Registriert: Mo 15. Jan 2018, 19:42
Ubuntu Version: Lubuntu 18.04.4 LTS
Wohnort: Wörgl

Lautsprecher knack'sen ....

Beitrag von angelwer1953 » Di 16. Jan 2018, 17:34

Guten Tag, ....
wie ich schon mal im "alten Forum" berichtet habe, konnte ich das Problem mit dem Lautsprecher-knack'sen,
bis heute nicht lösen. Na-ja, eigentlich knackt's nicht immer, manchmal aber auch durchgehend und manchmal
beim Start des PC's ein, zwei mal und dann in der ganzen Sitzung nicht mehr.
Ein Hardware-Problem kann ausgeschlossen werden, da ich den Laptop bei einer Computer-Service-Stelle
überprüfen hab' lassen.
Nun habe ich über'n Sommer, ein wenig "ge'Googel't", mit folgendem Ergebnis;
Zitat: Die Ursache des Problem's sind die Energiespareinstellungen von ALSA, um dieses Verhalten zu deaktivieren
muß man in der Datei > /etc/modprobe.d/alsa-base.conf < die folgenden Zeilen abändern:
options snd-hda-intel power_save=10 power_save_controller=N
Das Ganze sollte so aussehen:
options snd-hda-intel power_save=0 power_save_controller=N
Dies sollte die Energiesparmaßnahme abschalten und somit das Knacken verhindern.
So weit - so gut, .... aber, wie komme ich nun am PC an diese Datei?
Muß ich in Terminal (Konsole), diesem Befehl etwas zuvor setzen, wie z.B.: "sudo" oder "nano", oder irgend
etwas anderes, um zu dieser Datei zu gelangen, denn mein Rechner kennt diese Datei nicht! .... ??
Also, auf "Lubuntu" hätte ich unter >Zubehör< "Leafpad und LXTerminal" und unter >Systemwerkzeuge< "UXTerm und XTerm"
als Konsole anzubieten.
Mit freundlichen Grüssen und Dank im Voraus .... Werner



Benutzeravatar
Webbutterfly
Administrator
Beiträge: 159
Registriert: Mi 29. Nov 2017, 16:53
Ubuntu Version: 16.04
Wohnort: Wien
Kontaktdaten:

Re: Lautsprecher knack'sen ....

Beitrag von Webbutterfly » Di 16. Jan 2018, 18:57

Hello Werner

Du öffnest mal das Terminal in
>Systemwerkzeuge >LXTerminal
dort eingeben

Code: Alles auswählen

sudo leafpad /etc/modprobe.d/alsa-base.conf
nun wirst du nach deinem Passwort gefragt >eingeben (es wird nichts angezeigt!) und enter
jetzt öffnet sich die passende Datei, dort, ganz unten deine Zeile eintragen

Code: Alles auswählen

options snd-hda-intel power_save=0 power_save_controller=N
Datei speichern und noch den Rechner neu starten...

PS: Nehme an, dass du Lubunu hast, sonst schaut es natürlich anders aus :mrgreen:

Hier ein Video, dass dir den ganzen Ablauf zeigt:
[BBvideo=640,360]https://youtu.be/Mh4Y5ahJlgQ[/BBvideo]
European Open Source Center
www.eosc.eu

angelwer1953
Beiträge: 30
Registriert: Mo 15. Jan 2018, 19:42
Ubuntu Version: Lubuntu 18.04.4 LTS
Wohnort: Wörgl

Re: Lautsprecher knack'sen ....

Beitrag von angelwer1953 » Fr 19. Jan 2018, 17:04

Hallo Webbutterfly, habe alles so gemacht, wie von dir beschrieben (bzw. ein Video zum besseren Verständnis ist Super).
Na-ja, das Knacken war wohl noch nicht ganz verschwunden, obwohl eine Zeitlang, war's wohltuend still, es kam erst wieder zurück, als ich auf YouTube ein Video ansehen wollte. Ich dachte mir schon, oh-je ... wieder nix!
Ja, .... und dann fiel mir ein, was ich mal über die Konfiguration von HDA gelesen hatte:
Z.B.: Sony-Vaio, Zitat:
Um die Kopfhörerbuchse (inkl. automatischen Umschalten zwischen Lautsprecher und Kopfhörer) zu aktivieren muß der Datei >> /etc/modprobe.d/alsa-base.conf << folgende Zeile hinzugefügt werden (siehe auch Soundkartenkonfiguration/HDA): >> options snd-hda-intel model=vaio <<.
Ich hab's so verstanden, dass ich der HDA unter Linux sagen muss, dass der Computer ein "Sony Vaio" ist! ... ??
Gesagt-getan, .... oh, welch' ein Wunder, diese Stille, .... kein nerviges Rattern mehr, auch nicht mit YouTube!
Schau'n wir mal, wie lange es anhält!
Dennnoch, ohne dich, liebe "Marion-Webbutterfly" und dem Ubuntu-Austria-Forum, hätte ich den "Pfad zur Datei", wohl niiie gefunden!
Ich hab' schon gewußt, dass man einen Editor öffnen muß und dass unter Lubuntu dieser "Leafpad" heißt, aber ich hab' ihn an der falschen Stelle gesucht, denn unter "Zubehör" bei "Anwendungsfinder" ist so ein Leafpad-Button, der aber nicht's nützt, weil, der Computer findet obgenannte Datei hier nicht, auch das LXTerminal ist hier zu finden und nicht bei "Systemwerkzeuge", dort findet man nur UXTerm und XTerm. Na-ja, ein kleiner Unterschied zwischen Ubuntu und Lubuntu muss wohl sein! ...?

Ein lieber Gruss und Danke .... Werner
Zuletzt geändert von angelwer1953 am Sa 20. Jan 2018, 15:08, insgesamt 1-mal geändert.

haidi
Beiträge: 46
Registriert: Fr 12. Jan 2018, 22:06
Ubuntu Version: 16.04
Wohnort: Wien

Re: Lautsprecher knack'sen ....

Beitrag von haidi » Fr 19. Jan 2018, 17:54

Im Terminal eingeben:

sudo find / | Dateiname

wobei ich meist nur einen Teil des Dateinamens vewende und auf alle Fälle den Anfangsbuchstaben weglasse (wegen Groß- und Kleinschreibung).

Parameter für find findst unter https://wiki.ubuntuusers.de/find/
Barebone und Lenovo X200
Ubuntu 16.04 Gnome

Microsoft is not the answer. It's the question and the answer is NO.

angelwer1953
Beiträge: 30
Registriert: Mo 15. Jan 2018, 19:42
Ubuntu Version: Lubuntu 18.04.4 LTS
Wohnort: Wörgl

Re: Lautsprecher knack'sen ....

Beitrag von angelwer1953 » Di 6. Feb 2018, 17:59

Ja, .... eine schöne Zeit lang, hatte das Lautsprecher-Knack'sen, total aufgehört, .... aber, anscheinend zu früh gefreut,
ab und an ist es wieder da!
Am Schlimmsten ist es, beim Musik hören oder Video's schauen, .... und, so hab' ich mich entschlossen, wie schon früher, mit dem Kopfhörer über einen AreonDualUSB-Stick von Terratec zu hören. Leider aber, funktioniert der besagte USB-Stick, seit dem Neustart, meines Laptop's im letzten
Jahr nicht mehr! (14.04 Lubuntu). Muß ich nun irgendwo ein "Häk-chen" setzen, oder irgend etwas anderes irgendwo ändern? ... ?? (Alsamixer?).
2018-02-06-01_scrot.png
2018-02-06-01_scrot.png (246.32 KiB) 1041 mal betrachtet
Nun habe ich, wie schon früher, die Kopfhörer-Ausgangsbuchse (grün), am Laptop zugestöpselt, (man hört nicht's mehr)!
Die Version 14.04 neu Aufzusetzen, war notwendig geworden, weil sich kein "neur Kernel" speichern ließ, obwohl die neuesten Kerner-Update's
immer kamen, und so riet mir "Marion-Webbutterfly", zur Version 14.04, weil mein Rechner schon in die "Jahre" gekommen ist und er schon auf 14.04 gelaufen ist, (zur Zeit ist der Kernel 4.4.0-112-generic auf dem Rechner).

MfG. und Dank im Voraus .... Werner

Benutzeravatar
Webbutterfly
Administrator
Beiträge: 159
Registriert: Mi 29. Nov 2017, 16:53
Ubuntu Version: 16.04
Wohnort: Wien
Kontaktdaten:

Re: Lautsprecher knack'sen ....

Beitrag von Webbutterfly » Di 6. Feb 2018, 18:26

Hello Werner
...nu, du hast ja den Alsamixer offen, wenn du jetzt deine USB-Soundkarte anstöpselst
und dann F6 drückst, kannst du ja, mit den Pfeiltasten, die passende Soundkarte auswählen
(bei meinem Bild gibts nur eine...)
Nun habe ich, wie schon früher, die Kopfhörer-Ausgangsbuchse (grün), am Laptop zugestöpselt, (man hört nicht's mehr)!
...das verstehe ich nicht, wozu?
Bild
European Open Source Center
www.eosc.eu

angelwer1953
Beiträge: 30
Registriert: Mo 15. Jan 2018, 19:42
Ubuntu Version: Lubuntu 18.04.4 LTS
Wohnort: Wörgl

Re: Lautsprecher knack'sen ....

Beitrag von angelwer1953 » Mi 7. Feb 2018, 17:00

Zu Zitat:
"Nun habe ich, wie schon früher, die Kopfhörer-Ausgangsbuchse (grün), am Laptop zugestöpselt, (man hört nicht's mehr)!
Frage von Webbutterfly: .... das verstehe ich nicht, wozu?"

Meine Antwort:
Nun-ja, das Knack'sen geht am Laptop eigentlich nur auf den linken Lautsprecher (auch beim Headset), .... und so stöps'le ich
die Kopfhörer-Ausgangsbuchse, mit einem alten Kopfhörer, den ich unter dem Schreibtisch aufgehängt habe, zu!
Das Knack'sen ist schon noch da, aber ich höre es entweder nur sehr schwach, oder gar nicht mehr!

Musik hören tue ich mit Kopfhörer über den "AureonDualUSB"-Stick, aber der funktioniert, seit dem Neuaufsetzen des PC's im letzten Jahr,
nicht mehr und deshalb wollte ich wissen, ob ich irgendwo ein Häck-chen setzen muß, oder muß dieser Aureon-USB-Stick
neu Konfiguriert werden? Na-ja, vielleicht ist er auch defekt!?

MfG. Werner

P.S.: Beim Alsamixer, auf F6: Klangkarte auswählen, habe ich das Gleiche, wie bei dir!
Dateianhänge
2018-02-07-001_scrot.png
2018-02-07-001_scrot.png (100.63 KiB) 1027 mal betrachtet
Zuletzt geändert von angelwer1953 am Mi 7. Feb 2018, 17:13, insgesamt 1-mal geändert.

Benutzeravatar
Webbutterfly
Administrator
Beiträge: 159
Registriert: Mi 29. Nov 2017, 16:53
Ubuntu Version: 16.04
Wohnort: Wien
Kontaktdaten:

Re: Lautsprecher knack'sen ....

Beitrag von Webbutterfly » Mi 7. Feb 2018, 17:10

Hello
Nun-ja, das Knack'sen geht am Laptop eigentlich nur auf den linken Lautsprecher (auch beim Headset)
...auch wenn du den Ton abdrehst? Also auf stumm schaltest?
Glaube immer mehr, dass das "Knacksen" ein HW-Fehler ist, nur auf einer Seite... kann ein kleiner el. Funken sein...

Steck den USB an und gib dann im Terminal

Code: Alles auswählen

lsusb
ein...
Ausgabe kopieren und hier unter code als Text posten
European Open Source Center
www.eosc.eu

angelwer1953
Beiträge: 30
Registriert: Mo 15. Jan 2018, 19:42
Ubuntu Version: Lubuntu 18.04.4 LTS
Wohnort: Wörgl

Re: Lautsprecher knack'sen ....

Beitrag von angelwer1953 » Mi 7. Feb 2018, 17:50

Jessas-na, .... I' trau' mi im Forum gar nicht recht zu sagen bzw. schreiben, dass ich das "in Code kopieren" nicht kann!
Ich schreib' immer alles per "Hand" hinein, auch im Terminal, .... mir ist schon Bewußt, dass sich dadurch leicht Fehler einschleichen,
auch diesmal hab ich vom LXTerminal ein Bildschirmfoto gemacht! (siehe Dateianhang).
2018-02-07-002_scrot.png
2018-02-07-002_scrot.png (170.41 KiB) 1020 mal betrachtet

Benutzeravatar
Webbutterfly
Administrator
Beiträge: 159
Registriert: Mi 29. Nov 2017, 16:53
Ubuntu Version: 16.04
Wohnort: Wien
Kontaktdaten:

Re: Lautsprecher knack'sen ....

Beitrag von Webbutterfly » Mi 7. Feb 2018, 18:58

Hello
Wie man "Code" vom Terminal ins Forum einfügt ist hier zu sehen...
warum ich das so will... ich brauche nichts vom Screenshot mühsam abschreiben, ich kann dann auch kopieren und einfügen :mrgreen:
***
So, schau mal da, so bekommst du deine Terratec-Soundkarte zu laufen...
https://debianforum.de/forum/viewtopic. ... 4f#p869618

Info: Bei der Ausgabe mit lsusb wird deine Soundkarte angezeigt...
Kann ich jetzt nicht kopieren, das Screeshot ;)
Wichtig ist dort die Ausgabe: 0ccd:0077
Nach dem kann dann "geooglen" werden und dann gibt es eben Ergebnisse die genau auf das Gerät passen :ugeek:
European Open Source Center
www.eosc.eu

Gesperrt