fstab vor netzwerk

Wer Probleme mit Ubuntu außerhalb von LTS-Versionen hat, soll hier seine Frage stellen.
Diese Versionen werden nur 9 Monate nach erscheinen unterstützt
Antworten
Benutzeravatar
eltorro
Beiträge: 53
Registriert: Do 27. Sep 2018, 17:05
Ubuntu Version: 20/Mint/Ubuntu Studio/Manjaro
Wohnort: 1230

fstab vor netzwerk

Beitrag von eltorro » Di 2. Feb 2021, 12:54

Liebe Mitstreiter,

es ist kein echtes Ubuntu Thema, aber ein Linux Thema..(manjaro)
Wenn ich meinen kleinen 12" dell starte bindet mir das System die Netzwerk shares nicht ein.
Nach dem login kann ich mit mount -a aber alles normal mounten.
Die Fstab Einträge nutze ich ident auf mehreren Maschinen wo sie auch funktionieren.

Irgendwie ist beim Durchlauf der fstab noch kein Netzwerk verfügbar, weiß aber nicht wie ich dem System das beibringen kann vorher das WLAN zu starten...

Hat jemand eine gute Idee?

Danke
SG
Alois



Benutzeravatar
Webbutterfly
Administrator
Beiträge: 370
Registriert: Mi 29. Nov 2017, 16:53
Ubuntu Version: 20.04 & ChromeOS
Wohnort: Wien
Kontaktdaten:

Re: fstab vor netzwerk

Beitrag von Webbutterfly » Di 2. Feb 2021, 15:53

Hello
...schau dir Mal diesen Beitrag an:
http://wiki.blue-panel.com/index.php/Fs ... mount_(de)

Benutzeravatar
eltorro
Beiträge: 53
Registriert: Do 27. Sep 2018, 17:05
Ubuntu Version: 20/Mint/Ubuntu Studio/Manjaro
Wohnort: 1230

Re: fstab vor netzwerk

Beitrag von eltorro » Di 2. Feb 2021, 18:57

uups,
da ist was schief gelaufen..
Das ist jetzt meine fstab..

Code: Alles auswählen

//192.168.55.171/backup          /home/et/nas01/backup          cifs x-systemd.automount,noauto credentials=/etc/.smbcredentials,vers=2.0,uid=1000,gid=1000,file_mode=0775,dir_mode=0775,i>


//192.168.55.170/Datenaustausch /home/et/nas00/Datenaustausch   cifs x-systemd.automount,noauto credentials=/etc/.smbcredentials,vers=1.0,uid=1000,gid=1000,file_mode=0775,dir_mode=0775,i>
//192.168.55.170/Spiegel        /home/et/nas00/Spiegel          cifs x-systemd.automount,noauto credentials=/etc/.smbcredentials,vers=1.0,uid=1000,gid=1000,file_mode=0775,dir_mode=0775,i>
//192.168.55.170/Media          /home/et/nas00/Media            cifs x-systemd.automount,noauto credentials=/etc/.smbcredentials,vers=1.0,uid=1000,gid=1000,file_mode=0775,dir_mode=0775,i>

und das ist die Antwort beim mount...

Code: Alles auswählen

[et-de-ma et]# mount -a
mount: /etc/fstab: Einlesefehler in Zeile 17 -- ignoriert
mount: /etc/fstab: Einlesefehler in Zeile 20 -- ignoriert
mount: /etc/fstab: Einlesefehler in Zeile 21 -- ignoriert
mount: /etc/fstab: Einlesefehler in Zeile 22 -- ignoriert
[et-de-ma et]# 
und beim direkten zugriff via Dolfin..

Code: Alles auswählen

Beim Zugriff auf „/home/et/nas00/Media“ ist ein Fehler aufgetreten, die Meldung lautet: mount: /etc/fstab: Einlesefehler in Zeile 17 -- ignoriert
mount: /etc/fstab: Einlesefehler in Zeile 20 -- ignoriert
mount: /etc/fstab: Einlesefehler in Zeile 21 -- ignoriert
mount: /etc/fstab: Einlesefehler in Zeile 22 -- ignoriert
mount: /home/et/nas00/Media: konnte nicht in /etc/fstab gefunden werden.
mit Dieser Option habe ich schon experimentiert, bin aber immer gescheitert.

haidi
Beiträge: 142
Registriert: Fr 12. Jan 2018, 22:06
Ubuntu Version: 16.04
Wohnort: Wien

Re: fstab vor netzwerk

Beitrag von haidi » Mi 3. Feb 2021, 00:39

ich hatte das gleiche Problem in einem Windows-System und habe das bat-Files in etwa so gelöst, was sich in Linux auch umsetzen lassen sollte.

:reply
net use ........ (Verbindungsversuch mit einem im Netzwerk vorhandenen NAS)
if file nichtlöschen.txt goto ende
goto reply
:ende


nichtlöschen.txt ist eine leere Datei, mit der ich nur das Stehen der Verbindung feststelle.

Anmerkung: Die Syntax ist nicht korrekt, müsste da noch nachschlagen.
Barebone 18.04
Lenovo X200 16.04

Microsoft is not the answer. It's the question and the answer is NO.

Benutzeravatar
eltorro
Beiträge: 53
Registriert: Do 27. Sep 2018, 17:05
Ubuntu Version: 20/Mint/Ubuntu Studio/Manjaro
Wohnort: 1230

Re: fstab vor netzwerk [gelöst]

Beitrag von eltorro » Mi 3. Feb 2021, 14:26

24 Stunden später

nachdem alle Versuche mit x-systemd.... gescheitert sind habe ich einen eigentlich alten Beitrag aus 2011 gefunden
letzer Beitrag ganz unten
der die Option

Code: Alles auswählen

comment=systemd.automount
erwähnte, und was soll ich sagen:

Code: Alles auswählen

//192.168.55.171/backup          /home/et/nas01/backup          cifs noauto,comment=systemd.automount,credentials=/etc/.smbcredentials,vers=2.0,uid=1000,gid=1000,file_mode=0775,dir_mode=>


//192.168.55.170/Datenaustausch /home/et/nas00/Datenaustausch   cifs noauto,comment=systemd.automount,credentials=/etc/.smbcredentials,vers=1.0,uid=1000,gid=1000,file_mode=0775,dir_mode=>
//192.168.55.170/Spiegel        /home/et/nas00/Spiegel          cifs noauto,comment=systemd.automount,credentials=/etc/.smbcredentials,vers=1.0,uid=1000,gid=1000,file_mode=0775,dir_mode=>
//192.168.55.170/Media          /home/et/nas00/Media            cifs noauto,comment=systemd.automount,credentials=/etc/.smbcredentials,vers=1.0,uid=1000,gid=1000,file_mode=0775,dir_mode=>

Das hat funktioniert, und zwar jetzt unabhängig davon ob noauto, auto, oder defaults noch dabei ist..

Was diese Option
comment=systemd.automount
jetzt anders macht konnte ich noch nicht heraus finden, aber es funktioniert.

Danke für Eure Beiträge
SG
Alois

Antworten