Nach Update wieder kein internet :o(

Hier gehört alles hinein, dass mit der Version 18.04-LTS zu tun hat.
Diese Version wird bis April 2023 unterstützt
bennoliene
Beiträge: 33
Registriert: Sa 2. Dez 2017, 20:04
Ubuntu Version: Ubuntu 16.04
Wohnort: Wien
Kontaktdaten:

Nach Update wieder kein internet :o(

Beitrag von bennoliene » So 2. Sep 2018, 12:42

Hallo zusammen.
Nach dem letzten update habe ich das gleiche Problem wie im Thread: Neuer Computer-neue Probleme, allerdings funktioniert diesmal der Trick mit dem Umschaltender Antennen 1&2 nicht, da plötzlich beide Werte sehr schlecht sind.
Wenn ich die ältere Version boote läuft alles wie am Schnürchen.....

bennoiene@bennoiene-HP-Notebook:~$ sudo modprobe -r rtl8723be
bennoiene@bennoiene-HP-Notebook:~$ sudo modprobe rtl8723be ant_sel=1
bennoiene@bennoiene-HP-Notebook:~$ iwlist scan | egrep -i 'ssid|quality'
lo Interface doesn't support scanning.

enp1s0 Interface doesn't support scanning.

Quality=34/70 Signal level=-76 dBm
ESSID:"UPC0403822"
bennoiene@bennoiene-HP-Notebook:~$ sudo modprobe -r rtl8723be
bennoiene@bennoiene-HP-Notebook:~$ sudo modprobe rtl8723be ant_sel=2
bennoiene@bennoiene-HP-Notebook:~$ iwlist scan | egrep -i 'ssid|quality'
lo Interface doesn't support scanning.

enp1s0 Interface doesn't support scanning.

Quality=38/70 Signal level=-72 dBm
ESSID:"UPC0403822"


Danke für die Unterstüzuung :D
www.funracer.at

bennoliene
Beiträge: 33
Registriert: Sa 2. Dez 2017, 20:04
Ubuntu Version: Ubuntu 16.04
Wohnort: Wien
Kontaktdaten:

Re: Nach Update wieder kein internet :o(

Beitrag von bennoliene » So 2. Sep 2018, 12:48

Wenn ich das "alte" 4 0 15 32 boote schaut das so aus:
Quality=70/70 Signal level=-30 dBm
ESSID:"UPC0403822"
Danke für die Unterstüzuung :D
www.funracer.at

Benutzeravatar
Webbutterfly
Administrator
Beiträge: 235
Registriert: Mi 29. Nov 2017, 16:53
Ubuntu Version: 18.04 ChromeOS
Wohnort: Wien
Kontaktdaten:

Re: Nach Update wieder kein internet :o(

Beitrag von Webbutterfly » So 2. Sep 2018, 13:30

Liegt anscheinend am neuen Kernel 4.15.0-33 ;)
Hab im Moment keine Lösung (ist noch zu neu), außer das du im Moment mal den alten Kernel 4.15.0-32 weiter verwenden solltest...
...abwarten bis ein "Neuer" kommt und dann wieder testen

PS: Ist kein Problem, den älteren Kernel mal länger weiter zu verwenden...
European Open Source Center
www.eosc.eu

bennoliene
Beiträge: 33
Registriert: Sa 2. Dez 2017, 20:04
Ubuntu Version: Ubuntu 16.04
Wohnort: Wien
Kontaktdaten:

Re: Nach Update wieder kein internet :o(

Beitrag von bennoliene » So 2. Sep 2018, 13:33

Supi, vielen Dank für die Info.
LG Martin
:lol:
Danke für die Unterstüzuung :D
www.funracer.at

bennoliene
Beiträge: 33
Registriert: Sa 2. Dez 2017, 20:04
Ubuntu Version: Ubuntu 16.04
Wohnort: Wien
Kontaktdaten:

Re: Nach Update wieder kein internet :o(

Beitrag von bennoliene » Mo 29. Okt 2018, 19:44

Hello zusammen.
Mittlerweile hab ich den .38 Kernel und immer noch kein Internet (siehe letzten Eintrag) Der letzte funktionierende Kernel war .32 mit Unterstützung vom webbutterfly. Seit ,33 habe ich keinerlei Empfang mehr, weder mit Antenne 1, noch mit Antenne 2. Gibt es vielleich neue Erkenntnisse/Tipps?
Danke im Voraus, Martin
Danke für die Unterstüzuung :D
www.funracer.at

Benutzeravatar
Webbutterfly
Administrator
Beiträge: 235
Registriert: Mi 29. Nov 2017, 16:53
Ubuntu Version: 18.04 ChromeOS
Wohnort: Wien
Kontaktdaten:

Re: Nach Update wieder kein internet :o(

Beitrag von Webbutterfly » Mo 29. Okt 2018, 20:01

Es gibt da ein PPA das einen aktuellen Treiber beinhalten sollte...

Code: Alles auswählen

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt update
sudo apt install rtlwifi-new-dkms linux-firmware 
dann neu starten.
mal ausprobieren...
Sollte das nicht funktionieren, kannst du den Treiber noch selbst compilieren.
Quelle: https://aniketh01.github.io/Blog-single ... e-fix.html
European Open Source Center
www.eosc.eu

bennoliene
Beiträge: 33
Registriert: Sa 2. Dez 2017, 20:04
Ubuntu Version: Ubuntu 16.04
Wohnort: Wien
Kontaktdaten:

Re: Nach Update wieder kein internet :o(

Beitrag von bennoliene » Di 6. Nov 2018, 20:02

Hmmmm, danke für die Tipps, aber das Eine funktioniert nicht und für das Andere bin ich scheinbar zu dämlich. Hoffe mal, dass es bei irgendeinem zukünftigen Update ein fix gibt,

LG MM
Danke für die Unterstüzuung :D
www.funracer.at

bennoliene
Beiträge: 33
Registriert: Sa 2. Dez 2017, 20:04
Ubuntu Version: Ubuntu 16.04
Wohnort: Wien
Kontaktdaten:

Re: Nach Update wieder kein internet :o(

Beitrag von bennoliene » Mi 19. Dez 2018, 19:34

Hallo zusammen.
Das kommt raus, wenn ich oben beschriebenes in das Terminal eingebe:

OK:1 http://la-mirrors.evowise.com/ubuntu bionic InRelease
OK:2 http://la-mirrors.evowise.com/ubuntu bionic-updates InRelease
OK:3 http://la-mirrors.evowise.com/ubuntu bionic-backports InRelease
OK:4 http://la-mirrors.evowise.com/ubuntu bionic-security InRelease
Ign:5 http://dl.google.com/linux/chrome/deb stable InRelease
Ign:6 http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu bionic InRelease
Fehl:7 http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu bionic Release
404 Not Found [IP: 91.189.95.83 80]
OK:8 http://dl.google.com/linux/chrome/deb stable Release
OK:9 http://archive.canonical.com/ubuntu bionic InRelease
Paketlisten werden gelesen... Fertig
E: Das Depot »http://ppa.launchpad.net/hanipouspilot/rtlwifi/ubuntu bionic Release« enthält keine Release-Datei.
N: Eine Aktualisierung von solch einem Depot kann nicht auf eine sichere Art durchgeführt werden, daher ist es standardmäßig deaktiviert.
N: Weitere Details zur Erzeugung von Paketdepots sowie zu deren Benutzerkonfiguration finden Sie in der Handbuchseite apt-secure(8).
bennoiene@bennoiene-HP-Notebook:~$

Keine Ahnung was das soll....
Danke für die Unterstüzuung :D
www.funracer.at

Benutzeravatar
Webbutterfly
Administrator
Beiträge: 235
Registriert: Mi 29. Nov 2017, 16:53
Ubuntu Version: 18.04 ChromeOS
Wohnort: Wien
Kontaktdaten:

Re: Nach Update wieder kein internet :o(

Beitrag von Webbutterfly » Do 20. Dez 2018, 09:14

Das PPA ist leider nicht mehr aktuell... letze Tätigkeit 2016/9
Empfehlung:
Besorge dir diesen WLAN-Stick und deine Sorgen sind vorbei...
https://geizhals.at/tp-link-wireless-30 ... 63947.html
Einfach anstecken und funktioniert :)
European Open Source Center
www.eosc.eu

Benutzeravatar
stutz
Beiträge: 12
Registriert: Sa 9. Dez 2017, 14:05
Ubuntu Version: Debian7
Wohnort: Gars

Re: Nach Update wieder kein internet :o(

Beitrag von stutz » So 23. Dez 2018, 09:07

Hast du schon diese Antwort gefunden, ist zwar auf englisch aber nicht schwer.

https://askubuntu.com/questions/914048/ ... isconnects

GitHup: https://github.com/lwfinger/rtlwifi_new/
Diese Quelle wird auch im Post von Webbutterfly erwähnt. Nur das PPA war nicht mehr so aktuell. Den Code haben sie nicht selbst kompiliert. Dies wäre der nächste Schritt gewesen, um das Problem zu lösen.

Code: Alles auswählen

Its a problem with the drivers of Realtek RTL8723BE controller. Do this:

1) Get the new wifi drivers from github:

git clone https://github.com/lwfinger/rtlwifi_new/

2) Go into the directory:

cd rtlwifi_new

3) Build it:

make

4) Install:

sudo make install

Now, the new drivers are installed. To see what is the correct antenna configuration for your laptop, do this:

5) Unload the existing module:

sudo modprobe -r rtl8723be

6) Load the new module with antenna configuration:

sudo modprobe rtl8723be ant_sel=1

7) Now, check the wifi signals using:

iwlist scan | egrep -i 'ssid|quality'

Next, repeat the steps(5-7) with ant_sel=2 in step 6.

8) Whichever configuration gives the better signal quality, make it default by using:

echo "options rtl8723be ant_sel=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
---> Replace N with 1 or 2.

Note: After each kernel update, you need to rebuild the modules.
Der Befehl "git clone" kopiert die Daten von GitHup auf deinen Rechner. Du könntest die Daten auch herunterladen.
Off Topic
Yes, it works. I have done it twice. Once when I installed Ubuntu 18.04 and the second time when I had updated the kernel. – MaharshiRawal Sep 28 at 6:35
und hier

https://askubuntu.com/questions/1058379 ... -rtl8723be

GitHup: https://github.com/lwfinger/rtlwifi_new ... new_btcoex

Code: Alles auswählen



And finally I found a solution that works for me (checked on 2 laptops of same model with different versions of Ubuntu: 16.04LTS and 17.04)

    Open Terminal, and enter:

    iwconfig

    And note down the wl* number.

    Download the new driver rock.new_btcoex from Github and unzip it to Desktop folder.

    In Terminal, now run these commands:

    cd Desktop/rtlwifi_new-rock.new_btcoex
    make
    sudo make install` type your ubuntu password
    sudo modprobe -rv rtl8723be
    sudo modprobe -v rtl8723be ant_sel=2
    sudo ip link set wl* up` use your **wl* number**
    sudo iw dev wl* scan` same

To make the settings permanent, use this command:

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/50-rtl8723be.conf

[b]Note:[/b] After your OS (Kernel) update, you need to apply these settings again to get a strong signal.
Kompilieren
Kompilieren ist nicht schwer. Etwas Information.
https://wiki.ubuntuusers.de/Programme_kompilieren/

Antworten